XMPP comm/asterisk net/teamspeak (client and server) pidgin Coccinella Gizmo Jabbin Non-XMPP wip/sipwitch wip/py27-shtoom wip/twinkle CounterPath X-Lite net/Ekiga Kphone wip/linphone WengoPhone SpeakFreely Sjphone SIPSet What worked best: Jabbin Although it froze on first installation for me, Jabbin was the only XMPP VoIP that actually worked properly (sent and recieved Voice transmitions, instant messenger, etc.) How I got it to Work: 1) downloader jabber package 2) tweaked /etc/mk.conf : ACCEPTABLE_LICENSES+=lame-license PKG_OPTIONS.jabber=pam pgsql PGSQL_THREAD_SAFETY=yes X11_TYPE=xorg b) add the following to the end of rc.conf: jabberd=YES c2s=YES sm=YES s2s=YES router=YES resolver=YES 3) created a jabber database: # su pgsql $ createuser jabber $ createdb -O jabber jabber $ exit # cd /usr/pkgsrc/chat/jabber # make extract # cd work/jabber*/tools # su pgsql $ psql -U jabber jabber jabber=> \i db-setup.pgsql jabber=> \q $ exit # cd /usr/pkgsrc/chat/jabber # make clean 4) tweak /etc/rc.d/c2s by adding pgsql to the REQUIRE settings the entire header should like something like this: #!/bin/sh # # $NetBSD: c2s.sh,v 1.2 2004/06/26 11:21:46 abs Exp $ # # PROVIDE: c2s # REQUIRE: DAEMON pgsql 5) edit /usr/pkg/etc/jabberd/c2s.xml look under: Authentication/registration database configuration and set to: pgsql 6) registering accounts: you need at least 2 accounts (server and client) Server Account: server: localhost Jabber ID: gserver@localhost password: abc Client Account: server: localhost Jabber ID: gclient@localhost password: abc Jabber should run fairly well at this point. *NOTE* my netBSD came with G-System preinstalled and pretweaked. You may have to edit $HOME values if jabbin does not work.